main_panel无法启停消息服务且MQ日志报无法正常连接到回环地址的问题

现象:

1.启动main_panel的消息服务,发现windows服务面板中的SysPrintMessage并没有线程被调起,main_panel无法启停消息服务。Windows面版查看main_panel是被启用在A用户下的,在cmd窗口输入net start SysPrintMessage,返回拒绝访问;

2.MQ日志报无法正常连接到回环地址的错误。

原因:

1.司印服务需要bsprint_service账户在管理员组内,但是客户有较为严格的域策略,加域的服务器中非nbcb,nbcb_admin的管理员账户,重启后都会被域策略移出管理员组,bsprint_service就被移除了,如图1(正常情况下司印服务需要bsprint_service账户在管理员组内)。这导致运行在bsprint_service账户下的的消息服务无法从main_panel面板被正常启停。

2.客户的桌面管理软件会导致十几秒到二十几秒的网络初始化延迟现象,服务器性能差延迟时间可能会更长一些,这导致司印服务即使运行在system账户下,正常获取权限,服务器重启后,消息服务仍旧无法连接到回环地址、无法正常启动。

解决方法:

1、受bsprint_servive账号运行权限影响,客户现场无二次打印和mobile打印,所以目前所有服务都运行在system下。

2、SysPrintMain采用延迟启动的方法来解决刚开机时,产生的网络延迟现象导致的MQ服务无法及时连接到回环地址,正常启动的现象。

文章细节

文章编号:
128
分类:
添加日期:
2026-09-28 17:33:35
查看次数:
7
评价 (投票):
(0)

相关文章